summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2007-07-31 14:39:09 +0000
committerph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2007-07-31 14:39:09 +0000
commite188596ef3e912f62e3ae85c8da905a54fc41d8b (patch)
treeebd384645bf62c640a04fe0308bcbac05e8087e0 /CMakeLists.txt
parent235d0eb42c6281f0d8a1863f866c4d2722f0cdcf (diff)
downloadpcre-e188596ef3e912f62e3ae85c8da905a54fc41d8b.tar.gz
Daniel's patch for config.h and Windows DLL declarations (not fully working).
git-svn-id: svn://vcs.exim.org/pcre/code/trunk@199 2f5784b3-3f2a-0410-8824-cb99058d5e15
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 7 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a683995..29c7578 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,7 +58,7 @@ SET(PCRE_MATCH_LIMIT_RECURSION "MATCH_LIMIT" CACHE STRING
SET(PCRE_NEWLINE "LF" CACHE STRING
"What to recognize as a newline (one of CR, LF, CRLF, ANY).")
-SET(PCRE_NO_RECURSE ON CACHE BOOL
+SET(PCRE_NO_RECURSE OFF CACHE BOOL
"If ON, then don't use stack recursion when matching. See NO_RECURSE in config.h.in for details.")
SET(PCRE_POSIX_MALLOC_THRESHOLD "10" CACHE STRING
@@ -218,7 +218,6 @@ SET(PCRECPP_SOURCES
ADD_DEFINITIONS(-DHAVE_CONFIG_H)
IF(WIN32)
- # What about -DDLL_EXPORT?
ADD_DEFINITIONS(-D_CRT_SECURE_NO_DEPRECATE)
ENDIF(WIN32)
@@ -278,7 +277,7 @@ SET(ENV{pcretest} ${PCRETEST_EXE})
")
IF(UNIX)
- ADD_TEST(pcre_test ${CMAKE_SOURCE_DIR}/RunTest)
+ ADD_TEST(pcre_test ${CMAKE_SOURCE_DIR}/RunTest)
ADD_TEST(pcre_grep_test ${CMAKE_SOURCE_DIR}/RunGrepTest)
ENDIF(UNIX)
IF(WIN32)
@@ -317,7 +316,10 @@ FILE(GLOB man1 ${CMAKE_SOURCE_DIR}/doc/*.1)
FILE(GLOB man3 ${CMAKE_SOURCE_DIR}/doc/*.3)
IF(PCRE_BUILD_PCRECPP)
- INSTALL(TARGETS pcrecpp DESTINATION lib)
+ INSTALL(TARGETS pcrecpp
+ RUNTIME DESTINATION bin
+ LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION lib)
INSTALL(FILES ${PCRECPP_HEADERS} DESTINATION include)
ELSE(PCRE_BUILD_PCRECPP)
# Remove pcrecpp.3
@@ -332,6 +334,6 @@ ENDIF(PCRE_BUILD_PCRECPP)
INSTALL(FILES ${man1} DESTINATION man/man1)
INSTALL(FILES ${man3} DESTINATION man/man3)
-INSTALL(FILES ${html} DESTINATION doc/html)
+INSTALL(FILES ${html} DESTINATION share/doc/pcre/html)
# end CMakeLists.txt