summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2008-01-23 18:02:23 +0000
committerph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2008-01-23 18:02:23 +0000
commit8e7585f88c3d6a99b47bfb1755f76466745fe562 (patch)
treeef6907cfb02d8143f537a773da123a3ba0c06ae6 /CMakeLists.txt
parent30a48046b229205ae56c5dc20eb62269a1119595 (diff)
downloadpcre-8e7585f88c3d6a99b47bfb1755f76466745fe562.tar.gz
Remove the automatic build of pcredemo.
git-svn-id: svn://vcs.exim.org/pcre/code/trunk@312 2f5784b3-3f2a-0410-8824-cb99058d5e15
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 9 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ee419ec..57dc39b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,6 +24,7 @@
# be built with suffix of "-0.dll". (The libraries will be named
# libpcre-0.dll, libpcreposix-0.dll and libpcrecpp-0.dll - same names
# built by default with Configure and Make.
+# 2008-01-23 PH removed the automatic build of pcredemo.
PROJECT(PCRE C CXX)
@@ -361,12 +362,14 @@ TARGET_LINK_LIBRARIES(pcretest pcreposix ${PCRETEST_LIBS})
ADD_EXECUTABLE(pcregrep pcregrep.c)
TARGET_LINK_LIBRARIES(pcregrep pcreposix ${PCREGREP_LIBS})
-ADD_EXECUTABLE(pcredemo pcredemo.c)
-TARGET_LINK_LIBRARIES(pcredemo pcreposix)
-IF(NOT BUILD_SHARED_LIBS)
- # make sure to not use declspec(dllimport) in static mode on windows
- SET_TARGET_PROPERTIES(pcredemo PROPERTIES COMPILE_FLAGS "-DPCRE_STATIC")
-ENDIF(NOT BUILD_SHARED_LIBS)
+# Removed by PH (2008-01-23) because pcredemo shouldn't really be built
+# automatically, and it gave trouble in some environments anyway.
+# ADD_EXECUTABLE(pcredemo pcredemo.c)
+# TARGET_LINK_LIBRARIES(pcredemo pcreposix)
+# IF(NOT BUILD_SHARED_LIBS)
+# # make sure to not use declspec(dllimport) in static mode on windows
+# SET_TARGET_PROPERTIES(pcredemo PROPERTIES COMPILE_FLAGS "-DPCRE_STATIC")
+# ENDIF(NOT BUILD_SHARED_LIBS)
IF(PCRE_BUILD_PCRECPP)
ADD_EXECUTABLE(pcrecpp_unittest pcrecpp_unittest.cc)