summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2012-10-23 15:51:31 +0000
committerph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2012-10-23 15:51:31 +0000
commit15bb7299372497ffbc3bc2405ed84ec702e74bda (patch)
treec5023e1447f1ab942b8b348f00fb83a8b4a651d6 /CMakeLists.txt
parenteee548c8087d91ac94fb17b80f06f5780b3eaa40 (diff)
downloadpcre-15bb7299372497ffbc3bc2405ed84ec702e74bda.tar.gz
Check for gcc when coverage is enabled in CMake.
git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1167 2f5784b3-3f2a-0410-8824-cb99058d5e15
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 319ef0c..1b4f856 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -165,7 +165,7 @@ SET(PCRE_SUPPORT_VALGRIND OFF CACHE BOOL
"Enable Valgrind support.")
SET(PCRE_SUPPORT_COVERAGE OFF CACHE BOOL
- "Enable GCOV support.")
+ "Enable code coverage support using gcov.")
OPTION(PCRE_SHOW_REPORT "Show the final configuration report" ON)
OPTION(PCRE_BUILD_PCREGREP "Build pcregrep" ON)
@@ -298,6 +298,9 @@ ENDIF(PCRE_SUPPORT_VALGRIND)
IF(PCRE_SUPPORT_COVERAGE)
SET(SUPPORT_GCOV 1)
+ IF(NOT CMAKE_COMPILER_IS_GNUCC)
+ MESSAGE(FATAL_ERROR "Code coverage reports can only be generated when using GCC")
+ ENDIF(NOT CMAKE_COMPILER_IS_GNUCC)
ENDIF(PCRE_SUPPORT_COVERAGE)
# This next one used to contain