summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2008-01-20 20:36:45 +0000
committerph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2008-01-20 20:36:45 +0000
commit1d4f53aa517fc898d563c40cd36243653547177c (patch)
treea7aa0aa26702689fca61072bd95899aac484ebd7 /Makefile.am
parentc400f1c8bf37d753674497bbd450cd184dbdcc4a (diff)
downloadpcre-1d4f53aa517fc898d563c40cd36243653547177c.tar.gz
Add Ron Aaron's Makefile patch (experimentally).
git-svn-id: svn://vcs.exim.org/pcre/code/trunk@307 2f5784b3-3f2a-0410-8824-cb99058d5e15
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7b1babb..447ebd3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -302,6 +302,26 @@ pcredemo_LDADD = libpcre.la
# A compatibility line, the old build system worked with 'make test'
test: check ;
+
+# A PCRE user submitted the following addition, saying that it "will allow
+# anyone using the 'mingw32' compiler to simply type 'make pcre.dll' and get a
+# nice DLL for Windows use". (It is used by the pcre.dll target.)
+DLL_OBJS= pcre_compile.o pcre_config.o \
+ pcre_dfa_exec.o pcre_exec.o pcre_fullinfo.o pcre_get.o \
+ pcre_globals.o pcre_info.o pcre_maketables.o \
+ pcre_newline.o pcre_ord2utf8.o pcre_refcount.o \
+ pcre_study.o pcre_tables.o pcre_try_flipped.o \
+ pcre_ucp_searchfuncs.o pcre_valid_utf8.o pcre_version.o \
+ pcre_chartables.o \
+ pcre_xclass.o
+
+# A PCRE user submitted the following addition, saying that it "will allow
+# anyone using the 'mingw32' compiler to simply type 'make pcre.dll' and get a
+# nice DLL for Windows use".
+pcre.dll: $(DLL_OBJS)
+ $(CC) -shared -o pcre.dll -Wl,"--strip-all" -Wl,"--export-all-symbols" $(DLL_OBJS)
+
+
# We have .pc files for pkg-config users.
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libpcre.pc