summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2007-04-02 13:32:07 +0000
committerph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2007-04-02 13:32:07 +0000
commit538ef4f8d6632b422169714282844c34b4bfc271 (patch)
tree67867bc84c7834cad2a0c7c65340605c1a02ea9d /Makefile.am
parentf8735bf7b631d53067a040bd9f2c04b8f80c6dae (diff)
downloadpcre-538ef4f8d6632b422169714282844c34b4bfc271.tar.gz
Daniel's patches to add to the CMake support.
git-svn-id: svn://vcs.exim.org/pcre/code/trunk@144 2f5784b3-3f2a-0410-8824-cb99058d5e15
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 5986f36..9906793 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -63,7 +63,7 @@ lib_LTLIBRARIES =
# TESTS is for binary unit tests, check_SCRIPTS for script-based tests
TESTS =
check_SCRIPTS =
-noinst_SCRIPTS =
+dist_noinst_SCRIPTS =
# Some of the binaries we make are to be installed, and others are
# (non-user-visible) helper programs needed to build libpcre.
@@ -106,6 +106,12 @@ EXTRA_DIST += \
pcre.h.generic \
config.h.generic
+pcre.h.generic: configure.ac
+ rm -f $@
+ cp -p pcre.h $@
+
+MAINTAINERCLEANFILES += pcre.h.generic
+
# These are the header files we'll install. We do not distribute pcre.h because
# it is generated from pcre.h.in.
nodist_include_HEADERS = \
@@ -231,14 +237,14 @@ endif # WITH_PCRE_CPP
# ways. We install these test binaries in case folks find it helpful.
TESTS += RunTest
-noinst_SCRIPTS += RunTest
+dist_noinst_SCRIPTS += RunTest
EXTRA_DIST += RunTest.bat
bin_PROGRAMS += pcretest
pcretest_SOURCES = pcretest.c
pcretest_LDADD = libpcreposix.la
TESTS += RunGrepTest
-noinst_SCRIPTS += RunGrepTest
+dist_noinst_SCRIPTS += RunGrepTest
bin_PROGRAMS += pcregrep
pcregrep_SOURCES = pcregrep.c
pcregrep_LDADD = libpcreposix.la