summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2007-03-08 16:53:09 +0000
committerph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2007-03-08 16:53:09 +0000
commitfb65c97eca8a06b5ab09eb36dd32296fa441419f (patch)
treee663d21eede0bda3e34e9cd98312b0740f9fc72c /Makefile.am
parentfa85f5ee481179f3453200d51f3d797e455dd529 (diff)
downloadpcre-fb65c97eca8a06b5ab09eb36dd32296fa441419f.tar.gz
Create the PrepareRelease script to process the documentation and create the
.generic files for distribution, also to remove trailing spaces. Update a lot more of the build-time documentation. Arrange for PrepareRelease and its sub-scripts to be distributed. git-svn-id: svn://vcs.exim.org/pcre/code/trunk@111 2f5784b3-3f2a-0410-8824-cb99058d5e15
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am50
1 files changed, 33 insertions, 17 deletions
diff --git a/Makefile.am b/Makefile.am
index 557b79c..7dcf101 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,14 +4,11 @@ dist_doc_DATA = \
doc/pcre.txt \
doc/pcregrep.txt \
doc/pcretest.txt \
- doc/perltest.txt \
AUTHORS \
COPYING \
ChangeLog \
- INSTALL \
LICENCE \
NEWS \
- NON-UNIX-USE \
README
dist_html_DATA = \
@@ -80,25 +77,46 @@ MAINTAINERCLEANFILES =
# Additional files to bundle with the distribution.
EXTRA_DIST =
+# These files contain maintenance information
+EXTRA_DIST += \
+ doc/perltest.txt \
+ NON-UNIX-USE \
+ INSTALL
+
+# These files are used in the preparation of a release
+EXTRA_DIST += \
+ PrepareRelease \
+ CleanTxt \
+ Detrail \
+ 132html \
+ Index.html
+
# These files are to do with building for Virtual Pascal
EXTRA_DIST += \
makevp.bat \
!compile.txt \
!linklib.txt \
- pcregexp.pas
+ pcregexp.pas
+
+# These files are usable versions of pcre.h and config.h that are distributed
+# for the benefit of people who are building PCRE manually, without the
+# Autotools support.
+EXTRA_DIST += \
+ pcre.h.generic \
+ config.h.generic
-# These are the header files we'll install. Note that while pcre.h is
-# generated from pcre.h.in, we want to include it in the distribution so
-# that users building without Autotools support have an easier time of it.
+# These are the header files we'll install. We do not distribute pcre.h because
+# it is generated from pcre.h.in.
+nodist_include_HEADERS = \
+ pcre.h
include_HEADERS = \
- pcre.h \
pcreposix.h
-# These will be installed too, if C++ support is enabled. We don't
-# distribute pcrecpparg.h nor pcre_stringpiece.h, as these are generated
+# These additional headers will be be installed if C++ support is enabled. We
+# do not distribute pcrecpparg.h or pcre_stringpiece.h, as these are generated
# from corresponding .h.in files (which we do distribute).
if WITH_PCRE_CPP
-nodist_include_HEADERS = \
+nodist_include_HEADERS += \
pcrecpparg.h \
pcre_stringpiece.h
include_HEADERS += \
@@ -142,16 +160,14 @@ libpcre_la_SOURCES = \
ucp.h \
ucpinternal.h \
ucptable.h
-
+
## This file is generated as part of the building process, so don't distribute.
nodist_libpcre_la_SOURCES = \
pcre_chartables.c
-
+
# The pcre_printint.src file is #included by some source files, so it must be
-# distributed. In an Autotools world, config.h is generated from config.h.in,
-# but, like pcre.h, we want to include it in the distribution so that users
-# building without Autotools support have an easier time of it.
-EXTRA_DIST += pcre_printint.src config.h
+# distributed.
+EXTRA_DIST += pcre_printint.src
libpcre_la_LDFLAGS = $(EXTRA_LIBPCRE_LDFLAGS)