summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2012-01-21 16:37:17 +0000
committerph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2012-01-21 16:37:17 +0000
commitec7abfc6da4749a0deda01d514b353a43bdf39db (patch)
tree6236bb15f857322a56762945d3e9b84f6b393274 /Makefile.am
parent2e9472220441a6c61e9ed14f3fe3d33686e241b1 (diff)
downloadpcre-ec7abfc6da4749a0deda01d514b353a43bdf39db.tar.gz
Source file tidies for 8.30-RC1 release; fix Makefile.am bugs for building
symbolic links to man pages. git-svn-id: svn://vcs.exim.org/pcre/code/trunk@903 2f5784b3-3f2a-0410-8824-cb99058d5e15
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am54
1 files changed, 26 insertions, 28 deletions
diff --git a/Makefile.am b/Makefile.am
index f71339c..054640a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -520,34 +520,32 @@ dist_man_MANS = \
doc/pcreunicode.3
# Arrange for the per-function man pages to have 16-bit names as well.
-install-exec-hook:
- pushd $(DESTDIR)($man3dir)
- ln -s pcre_assign_jit_stack.3 pcre16_assign_jit_stack.3
- ln -s pcre_compile.3 pcre16_compile.3
- ln -s pcre_compile2.3 pcre16_compile2.3
- ln -s pcre_config.3 pcre16_config.3
- ln -s pcre_copy_named_substring.3 pcre16_copy_named_substring.3
- ln -s pcre_copy_substring.3 pcre16_copy_substring.3
- ln -s pcre_dfa_exec.3 pcre16_dfa_exec.3
- ln -s pcre_exec.3 pcre16_exec.3
- ln -s pcre_free_study.3 pcre16_free_study.3
- ln -s pcre_free_substring.3 pcre16_free_substring.3
- ln -s pcre_free_substring_list.3 pcre16_free_substring_list.3
- ln -s pcre_fullinfo.3 pcre16_fullinfo.3
- ln -s pcre_get_named_substring.3 pcre16_get_named_substring.3
- ln -s pcre_get_stringnumber.3 pcre16_get_stringnumber.3
- ln -s pcre_get_stringtable_entries.3 pcre16_get_stringtable_entries.3
- ln -s pcre_get_substring.3 pcre16_get_substring.3
- ln -s pcre_get_substring_list.3 pcre16_get_substring_list.3
- ln -s pcre_jit_stack_alloc.3 pcre16_jit_stack_alloc.3
- ln -s pcre_jit_stack_free.3 pcre16_jit_stack_free.3
- ln -s pcre_maketables.3 pcre16_maketables.3
- ln -s pcre_pattern_to_host_byte_order.3 pcre16_pattern_to_host_byte_order.3
- ln -s pcre_refcount.3 pcre16_refcount.3
- ln -s pcre_study.3 pcre16_study.3
- ln -s pcre_utf16_to_host_byte_order.3 pcre16_utf16_to_host_byte_order.3
- ln -s pcre_version.3 pcre16_version.3
- popd
+install-data-hook:
+ ln -s $(DESTDIR)$(man3dir)/pcre_assign_jit_stack.3 $(DESTDIR)$(man3dir)/pcre16_assign_jit_stack.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_compile.3 $(DESTDIR)$(man3dir)/pcre16_compile.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_compile2.3 $(DESTDIR)$(man3dir)/pcre16_compile2.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_config.3 $(DESTDIR)$(man3dir)/pcre16_config.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_copy_named_substring.3 $(DESTDIR)$(man3dir)/pcre16_copy_named_substring.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_copy_substring.3 $(DESTDIR)$(man3dir)/pcre16_copy_substring.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_dfa_exec.3 $(DESTDIR)$(man3dir)/pcre16_dfa_exec.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_exec.3 $(DESTDIR)$(man3dir)/pcre16_exec.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_free_study.3 $(DESTDIR)$(man3dir)/pcre16_free_study.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_free_substring.3 $(DESTDIR)$(man3dir)/pcre16_free_substring.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_free_substring_list.3 $(DESTDIR)$(man3dir)/pcre16_free_substring_list.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_fullinfo.3 $(DESTDIR)$(man3dir)/pcre16_fullinfo.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_get_named_substring.3 $(DESTDIR)$(man3dir)/pcre16_get_named_substring.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_get_stringnumber.3 $(DESTDIR)$(man3dir)/pcre16_get_stringnumber.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_get_stringtable_entries.3 $(DESTDIR)$(man3dir)/pcre16_get_stringtable_entries.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_get_substring.3 $(DESTDIR)$(man3dir)/pcre16_get_substring.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_get_substring_list.3 $(DESTDIR)$(man3dir)/pcre16_get_substring_list.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_jit_stack_alloc.3 $(DESTDIR)$(man3dir)/pcre16_jit_stack_alloc.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_jit_stack_free.3 $(DESTDIR)$(man3dir)/pcre16_jit_stack_free.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_maketables.3 $(DESTDIR)$(man3dir)/pcre16_maketables.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_pattern_to_host_byte_order.3 $(DESTDIR)$(man3dir)/pcre16_pattern_to_host_byte_order.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_refcount.3 $(DESTDIR)$(man3dir)/pcre16_refcount.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_study.3 $(DESTDIR)$(man3dir)/pcre16_study.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_utf16_to_host_byte_order.3 $(DESTDIR)$(man3dir)/pcre16_utf16_to_host_byte_order.3
+ ln -s $(DESTDIR)$(man3dir)/pcre_version.3 $(DESTDIR)$(man3dir)/pcre16_version.3
pcrecpp_man = doc/pcrecpp.3
EXTRA_DIST += $(pcrecpp_man)