summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2011-08-22 14:57:32 +0000
committerph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2011-08-22 14:57:32 +0000
commitff911da489a2d0eb1aa777cc2f8740c65b080f32 (patch)
tree69c0e76810e5db789573348eb099f2ce55d5a42c /Makefile.am
parentb205b9285d0feca53c32d7258fc02ecb926ca16b (diff)
downloadpcre-ff911da489a2d0eb1aa777cc2f8740c65b080f32.tar.gz
Commit all the changes for JIT support, but without any documentation yet.
git-svn-id: svn://vcs.exim.org/pcre/code/trunk@667 2f5784b3-3f2a-0410-8824-cb99058d5e15
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am31
1 files changed, 30 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 60ea3aa..2668538 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -174,6 +174,7 @@ libpcre_la_SOURCES = \
pcre_globals.c \
pcre_info.c \
pcre_internal.h \
+ pcre_jit_compile.c \
pcre_maketables.c \
pcre_newline.c \
pcre_ord2utf8.c \
@@ -196,10 +197,38 @@ nodist_libpcre_la_SOURCES = \
# pcre_chartables.c, used unless --enable-rebuild-chartables is specified.
EXTRA_DIST += pcre_printint.src pcre_chartables.c.dist
+# The JIT compiler lives in a separate directory, but its files are #included
+# when pcre_jit_compile.c is processed, so they must be distributed.
+EXTRA_DIST += \
+ sljit/sljitConfig.h \
+ sljit/sljitConfigInternal.h \
+ sljit/sljitExecAllocator.c \
+ sljit/sljitLir.c \
+ sljit/sljitLir.h \
+ sljit/sljitNativeARM_Thumb2.c \
+ sljit/sljitNativeARM_v5.c \
+ sljit/sljitNativeMIPS_32.c \
+ sljit/sljitNativeMIPS_common.c \
+ sljit/sljitNativePPC_32.c \
+ sljit/sljitNativePPC_64.c \
+ sljit/sljitNativePPC_common.c \
+ sljit/sljitNativeX86_32.c \
+ sljit/sljitNativeX86_64.c \
+ sljit/sljitNativeX86_common.c \
+ sljit/sljitUtils.c
+
libpcre_la_LDFLAGS = $(EXTRA_LIBPCRE_LDFLAGS)
CLEANFILES += pcre_chartables.c
+## If JIT support is enabled, arrange for the JIT test program to run.
+if WITH_JIT
+TESTS += pcre_jit_test
+noinst_PROGRAMS += pcre_jit_test
+pcre_jit_test_SOURCES = pcre_jit_test.c
+pcre_jit_test_LDADD = libpcre.la
+endif # WITH_JIT
+
## A version of the main pcre library that has a posix re API.
lib_LTLIBRARIES += libpcreposix.la
libpcreposix_la_SOURCES = \
@@ -321,7 +350,7 @@ test: check ;
# nice DLL for Windows use". (It is used by the pcre.dll target.)
DLL_OBJS= pcre_compile.o pcre_config.o \
pcre_dfa_exec.o pcre_exec.o pcre_fullinfo.o pcre_get.o \
- pcre_globals.o pcre_info.o pcre_maketables.o \
+ pcre_globals.o pcre_info.o pcre_jit_compile.o pcre_maketables.o \
pcre_newline.o pcre_ord2utf8.o pcre_refcount.o \
pcre_study.o pcre_tables.o pcre_try_flipped.o \
pcre_ucd.o pcre_valid_utf8.o pcre_version.o \