summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2013-07-01 12:28:12 +0000
committerph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2013-07-01 12:28:12 +0000
commit889d282ffb883c6525124423867d6c34706fbbe5 (patch)
tree97a7997e3a49a7be26aa79157db2f5aba89759d4 /configure.ac
parenta02886a03cad3a8fea3864d73bdd58cb858a675c (diff)
downloadpcre-889d282ffb883c6525124423867d6c34706fbbe5.tar.gz
Remove SUPPORT_GCOV from config.h, because it is not used and is misleading.
(Coverage support does not need any code changes.) git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1342 2f5784b3-3f2a-0410-8824-cb99058d5e15
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 91cb79a..1d7343a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -957,7 +957,7 @@ if test "$enable_pcretest_libreadline" = "yes"; then
fi
fi
-# Check for valgrind
+# Handle valgrind support
if test "$enable_valgrind" = "yes"; then
m4_ifdef([PKG_CHECK_MODULES],
@@ -965,7 +965,7 @@ if test "$enable_valgrind" = "yes"; then
[AC_MSG_ERROR([pkg-config not supported])])
fi
-# test code coverage reporting
+# Handle code coverage reporting support
if test "$enable_coverage" = "yes"; then
if test "x$GCC" != "xyes"; then
AC_MSG_ERROR([Code coverage reports can only be generated when using GCC])
@@ -996,11 +996,7 @@ if test "$enable_coverage" = "yes"; then
AC_MSG_ERROR([genhtml not found])
fi
- AC_DEFINE([SUPPORT_GCOV],[1], [
- Define to allow pcretest and pcregrep to be linked with gcov, so that they
- are able to generate code coverage reports.])
-
- # And add flags needed for gcov
+ # Set flags needed for gcov
GCOV_CFLAGS="-O0 -ggdb3 -fprofile-arcs -ftest-coverage"
GCOV_CXXFLAGS="-O0 -ggdb3 -fprofile-arcs -ftest-coverage"
GCOV_LIBS="-lgcov"