summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornigel <nigel@2f5784b3-3f2a-0410-8824-cb99058d5e15>2007-02-24 21:40:24 +0000
committernigel <nigel@2f5784b3-3f2a-0410-8824-cb99058d5e15>2007-02-24 21:40:24 +0000
commit4af6fcff808e079ca1aa09104d6146baa932af47 (patch)
treedc14f3624835dd1275c31159a4c365ed439f3df7 /configure.in
parentf08d5b6354f668c0047281d81eda8d0fd2a9e82d (diff)
downloadpcre-4af6fcff808e079ca1aa09104d6146baa932af47.tar.gz
Load pcre-4.4 into code/trunk.
git-svn-id: svn://vcs.exim.org/pcre/code/trunk@71 2f5784b3-3f2a-0410-8824-cb99058d5e15
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 5 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 5394f4f..69cb923 100644
--- a/configure.in
+++ b/configure.in
@@ -21,8 +21,8 @@ dnl digits for minor numbers less than 10. There are unlikely to be
dnl that many releases anyway.
PCRE_MAJOR=4
-PCRE_MINOR=3
-PCRE_DATE=21-May-2003
+PCRE_MINOR=4
+PCRE_DATE=21-August-2003
PCRE_VERSION=${PCRE_MAJOR}.${PCRE_MINOR}
dnl Default values for miscellaneous macros
@@ -146,7 +146,8 @@ AC_SUBST(PCRE_POSIXLIB_VERSION)
AC_SUBST(POSIX_MALLOC_THRESHOLD)
AC_SUBST(UTF8)
-dnl Stuff to make Win32 work better
+dnl Stuff to make MinGW work better. Special treatment is no longer
+dnl needed for Cygwin.
case $host_os in
mingw* )
@@ -157,14 +158,6 @@ mingw* )
NOT_ON_WINDOWS="#"
WIN_PREFIX=
;;
-cygwin* )
- ON_WINDOWS=
- POSIX_OBJ=pcreposix.o
- POSIX_LOBJ=pcreposix.lo
- POSIX_LIB=
- WIN_PREFIX=cyg
- NOT_ON_WINDOWS="#"
- ;;
* )
ON_WINDOWS="#"
NOT_ON_WINDOWS=
@@ -182,7 +175,7 @@ AC_SUBST(POSIX_LOBJ)
AC_SUBST(POSIX_LIB)
if test "x$enable_shared" = "xno" ; then
- AC_DEFINE(PCRE_STATIC,1)
+ AC_DEFINE([PCRE_STATIC],[1],[to link statically])
fi
dnl This must be last; it determines what files are written as well as config.h