summaryrefslogtreecommitdiff
path: root/cpan/Scalar-List-Utils/Makefile.PL
diff options
context:
space:
mode:
authorSteve Hay <steve.m.hay@googlemail.com>2013-10-24 18:09:14 +0100
committerSteve Hay <steve.m.hay@googlemail.com>2013-10-24 18:09:14 +0100
commitcb8c84586a7e77e1b9100e6d88a6a9d18041ae96 (patch)
treef6a0ebbe9f044f2eb27b0dc48936103198ca8b60 /cpan/Scalar-List-Utils/Makefile.PL
parent41e70615a0bf7f35048f8163e68f1b9936509b9a (diff)
downloadperl-cb8c84586a7e77e1b9100e6d88a6a9d18041ae96.tar.gz
Move Cwd and List-Util to folders named as per their CPAN distributions
Diffstat (limited to 'cpan/Scalar-List-Utils/Makefile.PL')
-rw-r--r--cpan/Scalar-List-Utils/Makefile.PL46
1 files changed, 46 insertions, 0 deletions
diff --git a/cpan/Scalar-List-Utils/Makefile.PL b/cpan/Scalar-List-Utils/Makefile.PL
new file mode 100644
index 0000000000..5068e34598
--- /dev/null
+++ b/cpan/Scalar-List-Utils/Makefile.PL
@@ -0,0 +1,46 @@
+# -*- perl -*-
+BEGIN { require 5.006; }
+use strict;
+use warnings;
+use Config;
+use File::Spec;
+use ExtUtils::MakeMaker;
+my $PERL_CORE = grep { $_ eq 'PERL_CORE=1' } @ARGV;
+
+WriteMakefile(
+ NAME => q[List::Util],
+ ABSTRACT => q[Common Scalar and List utility subroutines],
+ AUTHOR => q[Graham Barr <gbarr@cpan.org>],
+ DEFINE => q[-DPERL_EXT],
+ DISTNAME => q[Scalar-List-Utils],
+ VERSION_FROM => 'lib/List/Util.pm',
+
+ # We go through the ListUtil.xs trickery to foil platforms
+ # that have the feature combination of
+ # (1) static builds
+ # (2) allowing only one object by the same name in the static library
+ # (3) the object name matching being case-blind
+ # This means that we can't have the top-level util.o
+ # and the extension-level Util.o in the same build.
+ # One such platform is the POSIX-BC BS2000 EBCDIC mainframe platform.
+ XS => {'ListUtil.xs' => 'ListUtil.c'},
+ OBJECT => 'ListUtil$(OBJ_EXT)',
+ ( $PERL_CORE
+ ? ()
+ : (
+ INSTALLDIRS => ($] < 5.011 ? q[perl] : q[site]),
+ PREREQ_PM => {'Test::More' => 0,},
+ (eval { ExtUtils::MakeMaker->VERSION(6.31) } ? (LICENSE => 'perl') : ()),
+ ( eval { ExtUtils::MakeMaker->VERSION(6.46) } ? (
+ META_MERGE => {
+ resources => { ##
+ repository => 'https://github.com/Scalar-List-Utils/Scalar-List-Utils',
+ },
+ }
+ )
+ : ()
+ ),
+ )
+ ),
+);
+