summaryrefslogtreecommitdiff
path: root/cpan/Unicode-Collate/Makefile.PL
diff options
context:
space:
mode:
authorChris 'BinGOs' Williams <chris@bingosnet.co.uk>2011-01-16 23:23:03 +0000
committerChris 'BinGOs' Williams <chris@bingosnet.co.uk>2011-01-17 00:22:13 +0000
commit211cc5012284f4bd900fcaa630adbcac69ca6112 (patch)
tree7f07e1acee7dd8b86e8816730d8a975a4946d477 /cpan/Unicode-Collate/Makefile.PL
parenta62b1201c068dc7b099bcb7182e188c4d2fbf34c (diff)
downloadperl-211cc5012284f4bd900fcaa630adbcac69ca6112.tar.gz
Update Unicode-Collate to CPAN version 0.70 and enable XS version
[DELTA] 0.70 Sun Jan 16 20:31:07 2011 - Now U::C::Locale->new will use the compiled DUCET via XS. 0.69 Sat Jan 15 19:41:11 2011 - clarified about XSUB. revised INSTALL in README. - xs: flag passed to utf8n_to_uvuni(). - doc and comments: [perl #81876] Fix typos by Peter J. Acklam. A pure-perl version of this module was previously installed, this commit enables the XS version of the module instead.
Diffstat (limited to 'cpan/Unicode-Collate/Makefile.PL')
-rw-r--r--cpan/Unicode-Collate/Makefile.PL28
1 files changed, 28 insertions, 0 deletions
diff --git a/cpan/Unicode-Collate/Makefile.PL b/cpan/Unicode-Collate/Makefile.PL
new file mode 100644
index 0000000000..30d6fc0aee
--- /dev/null
+++ b/cpan/Unicode-Collate/Makefile.PL
@@ -0,0 +1,28 @@
+require 5.006001;
+use ExtUtils::MakeMaker;
+
+my $clean = {};
+
+if (-f "Collate.xs") {
+ print STDERR "Making header files for XS...\n";
+
+ do 'mkheader' or die $@ || "mkheader: $!";
+
+ $clean = { FILES => 'ucatbl.h' };
+}
+
+WriteMakefile(
+ 'INSTALLDIRS' => $] >= 5.007002 ? 'perl' : 'site',
+ 'NAME' => 'Unicode::Collate',
+ 'VERSION_FROM' => 'Collate.pm', # finds $VERSION
+ 'clean' => $clean,
+ 'PREREQ_PM' => {
+ Carp => 0,
+ constant => 0,
+ DynaLoader => 0,
+ File::Spec => 0,
+ strict => 0,
+ Test => 0,
+ warnings => 0,
+ },
+);