summaryrefslogtreecommitdiff
path: root/cpan/Win32/Makefile.PL
diff options
context:
space:
mode:
authorNicholas Clark <nick@ccl4.org>2009-10-02 17:57:13 +0100
committerNicholas Clark <nick@ccl4.org>2009-10-02 17:57:13 +0100
commit43aed010bf8b6e3fe32d5f9e8e086dda22b5b4c6 (patch)
tree8079ba2a658289bdccc9cff62d201268b0173612 /cpan/Win32/Makefile.PL
parent610892605b3814cdf4f5f2215ee00d25d7ffba45 (diff)
downloadperl-43aed010bf8b6e3fe32d5f9e8e086dda22b5b4c6.tar.gz
Move Win32 from ext/ to cpan/
Diffstat (limited to 'cpan/Win32/Makefile.PL')
-rw-r--r--cpan/Win32/Makefile.PL18
1 files changed, 18 insertions, 0 deletions
diff --git a/cpan/Win32/Makefile.PL b/cpan/Win32/Makefile.PL
new file mode 100644
index 0000000000..6f9b008823
--- /dev/null
+++ b/cpan/Win32/Makefile.PL
@@ -0,0 +1,18 @@
+use 5.006;
+use strict;
+use warnings;
+use ExtUtils::MakeMaker;
+
+unless ($^O eq "MSWin32" || $^O eq "cygwin") {
+ die "OS unsupported\n";
+}
+
+my %param = (
+ NAME => 'Win32',
+ VERSION_FROM => 'Win32.pm',
+ INSTALLDIRS => ($] >= 5.008004 ? 'perl' : 'site'),
+);
+$param{NO_META} = 1 if eval "$ExtUtils::MakeMaker::VERSION" >= 6.10_03;
+$param{LIBS} = ['-L/lib/w32api -lole32 -lversion'] if $^O eq "cygwin";
+
+WriteMakefile(%param);