summaryrefslogtreecommitdiff
path: root/dist/Safe/Makefile.PL
diff options
context:
space:
mode:
authorNicholas Clark <nick@ccl4.org>2009-09-28 16:13:11 +0100
committerNicholas Clark <nick@ccl4.org>2009-09-29 11:12:38 +0100
commit5a4811be25e2c4fa466997f8fc1ac08c1abddb9e (patch)
tree8add352aba63d0bffc05076f03aa774b04085d58 /dist/Safe/Makefile.PL
parentea6a18807a96ca23333934a286429145ae29eea4 (diff)
downloadperl-5a4811be25e2c4fa466997f8fc1ac08c1abddb9e.tar.gz
Move Safe from ext/ to dist/
Diffstat (limited to 'dist/Safe/Makefile.PL')
-rw-r--r--dist/Safe/Makefile.PL10
1 files changed, 10 insertions, 0 deletions
diff --git a/dist/Safe/Makefile.PL b/dist/Safe/Makefile.PL
new file mode 100644
index 0000000000..0463e9c7db
--- /dev/null
+++ b/dist/Safe/Makefile.PL
@@ -0,0 +1,10 @@
+use ExtUtils::MakeMaker;
+
+my $core = grep { $_ eq 'PERL_CORE=1' } @ARGV;
+
+WriteMakefile(
+ NAME => 'Safe',
+ VERSION_FROM => 'Safe.pm',
+ INSTALLDIRS => 'perl',
+ ($core || $] >= 5.011) ? () : (INST_LIB => '$(INST_ARCHLIB)'),
+);