summaryrefslogtreecommitdiff
path: root/ext/Compress/Zlib/Makefile.PL
diff options
context:
space:
mode:
authorRafael Garcia-Suarez <rgarciasuarez@gmail.com>2005-09-06 19:06:38 +0000
committerRafael Garcia-Suarez <rgarciasuarez@gmail.com>2005-09-06 19:06:38 +0000
commit76e6f3895c818bfa261702680a56759831e015be (patch)
tree82824479103de9a1164300a22cf675556872ba88 /ext/Compress/Zlib/Makefile.PL
parent740266bff261335d346cbafd47b3f0ad938f70d0 (diff)
downloadperl-76e6f3895c818bfa261702680a56759831e015be.tar.gz
Upgrade to Compress::Zlib 1.38
p4raw-id: //depot/perl@25361
Diffstat (limited to 'ext/Compress/Zlib/Makefile.PL')
-rwxr-xr-xext/Compress/Zlib/Makefile.PL13
1 files changed, 13 insertions, 0 deletions
diff --git a/ext/Compress/Zlib/Makefile.PL b/ext/Compress/Zlib/Makefile.PL
index b0fc295bfc..eea4402e7c 100755
--- a/ext/Compress/Zlib/Makefile.PL
+++ b/ext/Compress/Zlib/Makefile.PL
@@ -168,6 +168,19 @@ else {
or die "Can't copy fallback.xs to constants.xs: $!";
}
+sub MY::libscan
+{
+ my $self = shift ;
+ my $path = shift ;
+
+ return undef
+ if $path =~ /(~|\.bak|_bak)$/ ||
+ $path =~ /^\..*\.swp$/ ;
+
+ return $path;
+}
+
+
sub MY::postamble
{
my $postamble = <<'EOM';