summaryrefslogtreecommitdiff
path: root/ext/SDBM_File/Makefile.PL
diff options
context:
space:
mode:
authorBenjamin Stuhl <sho_pi@hotmail.com>2000-11-13 07:08:08 -0800
committerJarkko Hietaniemi <jhi@iki.fi>2000-11-14 01:21:09 +0000
commite601c439adce167078ac7b49550c0418ace86f94 (patch)
tree5cf09c48cc83a16ea460db17f84afc45830116d0 /ext/SDBM_File/Makefile.PL
parent0db725d892efd38f45ece17a9db22f98fb713bb3 (diff)
downloadperl-e601c439adce167078ac7b49550c0418ace86f94.tar.gz
Get PerlIO building on Win32
Message-ID: <20001113230808.18659.qmail@web6305.mail.yahoo.com> p4raw-id: //depot/perl@7679
Diffstat (limited to 'ext/SDBM_File/Makefile.PL')
-rw-r--r--ext/SDBM_File/Makefile.PL21
1 files changed, 15 insertions, 6 deletions
diff --git a/ext/SDBM_File/Makefile.PL b/ext/SDBM_File/Makefile.PL
index a1debb92a3..bff3e7b3bc 100644
--- a/ext/SDBM_File/Makefile.PL
+++ b/ext/SDBM_File/Makefile.PL
@@ -1,4 +1,5 @@
use ExtUtils::MakeMaker;
+use Config;
# The existence of the ./sdbm/Makefile.PL file causes MakeMaker
# to automatically include Makefile code for the targets
@@ -21,18 +22,26 @@ WriteMakefile(
sub MY::postamble {
if ($^O =~ /MSWin32/ && Win32::IsWin95()) {
- # XXX: dmake-specific, like rest of Win95 port
- return
- '
+ if ($Config{'make'} =~ /dmake/i) {
+ # dmake-specific
+ return <<EOT;
$(MYEXTLIB): sdbm/Makefile
@[
cd sdbm
$(MAKE) all
cd ..
]
-';
- }
- elsif ($^O ne 'VMS') {
+EOT
+ } elsif ($Config{'make'} =~ /nmake/i) {
+ #
+ return <<'EOT';
+$(MYEXTLIB): sdbm/Makefile
+ cd sdbm
+ $(MAKE) all
+ cd ..
+EOT
+ }
+ } elsif ($^O ne 'VMS') {
'
$(MYEXTLIB): sdbm/Makefile
cd sdbm && $(MAKE) all