summaryrefslogtreecommitdiff
path: root/ext/Win32/Makefile.PL
diff options
context:
space:
mode:
authorSteve Hay <SteveHay@planit.com>2007-05-18 10:46:57 +0000
committerSteve Hay <SteveHay@planit.com>2007-05-18 10:46:57 +0000
commit34f7f30df6fcd985e62d43a002d5a25b03156758 (patch)
tree9cdd57e82b6b09a5eee4c34e762aea38ca92c43b /ext/Win32/Makefile.PL
parent87a942b162c36e60410b29a97a6709efc34b9f98 (diff)
downloadperl-34f7f30df6fcd985e62d43a002d5a25b03156758.tar.gz
Upgrade to Win32-0.29
p4raw-id: //depot/perl@31235
Diffstat (limited to 'ext/Win32/Makefile.PL')
-rw-r--r--ext/Win32/Makefile.PL11
1 files changed, 8 insertions, 3 deletions
diff --git a/ext/Win32/Makefile.PL b/ext/Win32/Makefile.PL
index b6f5744f10..742c50d558 100644
--- a/ext/Win32/Makefile.PL
+++ b/ext/Win32/Makefile.PL
@@ -1,10 +1,15 @@
+use 5.006;
use ExtUtils::MakeMaker;
my @libs;
push @libs, '-L/lib/w32api -lole32 -lversion' if $^O eq "cygwin";
WriteMakefile(
- NAME => 'Win32',
- VERSION_FROM => 'Win32.pm',
- LIBS => \@libs,
+ NAME => 'Win32',
+ VERSION_FROM => 'Win32.pm',
+ LIBS => \@libs,
+ INSTALLDIRS => ($] >= 5.008004 ? 'perl' : 'site'),
+
+ AUTHOR => 'Jan Dubois <jand@activestate.com>',
+ ABSTRACT_FROM => 'Win32.pm',
);