summaryrefslogtreecommitdiff
path: root/ext/XS-APItest/Makefile.PL
diff options
context:
space:
mode:
authorRobin Barker <rmbarker@cpan.org>2010-08-23 15:32:45 +0100
committerFlorian Ragwitz <rafl@debian.org>2010-08-28 13:08:48 +0200
commit95ddc6755c1ff41d06e5afc2212c85f918ebcd28 (patch)
treed28cef3d7e4113d3c6379e37d5cee68aa3ce9466 /ext/XS-APItest/Makefile.PL
parent3644ba605f91a58759bac00d5712cb8c92bea6dc (diff)
downloadperl-95ddc6755c1ff41d06e5afc2212c85f918ebcd28.tar.gz
silence APItest deprecation warning
Diffstat (limited to 'ext/XS-APItest/Makefile.PL')
-rw-r--r--ext/XS-APItest/Makefile.PL3
1 files changed, 3 insertions, 0 deletions
diff --git a/ext/XS-APItest/Makefile.PL b/ext/XS-APItest/Makefile.PL
index 10ce8774ad..24b8f10403 100644
--- a/ext/XS-APItest/Makefile.PL
+++ b/ext/XS-APItest/Makefile.PL
@@ -1,6 +1,7 @@
use 5.008;
use ExtUtils::MakeMaker;
use ExtUtils::Constant 0.11 'WriteConstants';
+use Config;
# See lib/ExtUtils/MakeMaker.pm for details of how to influence
# the contents of the Makefile that is written.
WriteMakefile(
@@ -18,6 +19,8 @@ WriteMakefile(
# Un-comment this if you add C files to link with later:
# 'OBJECT' => '$(O_FILES)', # link all the C files too
realclean => {FILES => 'const-c.inc const-xs.inc'},
+ ($Config{gccversion} && $Config{d_attribute_deprecated} ?
+ (CCFLAGS => '-Wno-deprecated-declarations') : ()),
);
WriteConstants(