summaryrefslogtreecommitdiff
path: root/ext/re/Makefile.PL
diff options
context:
space:
mode:
authorHans Mulder <hansmu@xs4all.nl>1998-07-13 04:52:27 -0700
committerGurusamy Sarathy <gsar@cpan.org>1998-07-14 06:38:15 +0000
commit778ddebdd36200650e05e3789258e36307a5988b (patch)
treeb84c84b307381381e0f52bb7f7ce4227b299b709 /ext/re/Makefile.PL
parent384f7be5bc08c545c16bd631c7ca9f54fc7d23dc (diff)
downloadperl-778ddebdd36200650e05e3789258e36307a5988b.tar.gz
applied patch, slightly tweaked
Message-Id: <3.0.5.32.19980713115227.00a73970@ous.edu> Subject: [PATCH 5.004_73]Get re module working on VMS p4raw-id: //depot/perl@1486
Diffstat (limited to 'ext/re/Makefile.PL')
-rw-r--r--ext/re/Makefile.PL18
1 files changed, 18 insertions, 0 deletions
diff --git a/ext/re/Makefile.PL b/ext/re/Makefile.PL
index e21b923b29..9ed83d17c8 100644
--- a/ext/re/Makefile.PL
+++ b/ext/re/Makefile.PL
@@ -10,6 +10,23 @@ WriteMakefile(
);
sub MY::postamble {
+ if ($^O eq 'VMS') {
+ return <<'VMS_EOF';
+re_comp.c : [--]regcomp.c
+ - $(RM_F) $(MMS$TARGET_NAME)
+ $(CP) [--]regcomp.c $(MMS$TARGET_NAME)
+
+re_comp$(OBJ_EXT) : re_comp.c
+
+re_exec.c : [--]regexec.c
+ - $(RM_F) $(MMS$TARGET_NAME)
+ $(CP) [--]regexec.c $(MMS$TARGET_NAME)
+
+re_exec$(OBJ_EXT) : re_exec.c
+
+
+VMS_EOF
+ } else {
return <<'EOF';
re_comp.c: ../../regcomp.c
-$(RM_F) $@
@@ -20,4 +37,5 @@ re_exec.c: ../../regexec.c
$(CP) ../../regexec.c $@
EOF
+ }
}