summaryrefslogtreecommitdiff
path: root/ext/re/Makefile.PL
diff options
context:
space:
mode:
authorJarkko Hietaniemi <jhi@iki.fi>2000-08-23 13:58:41 +0000
committerJarkko Hietaniemi <jhi@iki.fi>2000-08-23 13:58:41 +0000
commit472390e15c17c4c1655b51bde3088514660cf301 (patch)
tree2829a2bd254c8e69f2c2e8388d7d6d9b18b0862f /ext/re/Makefile.PL
parent5e05dca5eeb6b4b7bde6dcfeb92fbbed8c17d405 (diff)
downloadperl-472390e15c17c4c1655b51bde3088514660cf301.tar.gz
Portability fix from Hugo van der Sanden.
p4raw-id: //depot/perl@6784
Diffstat (limited to 'ext/re/Makefile.PL')
-rw-r--r--ext/re/Makefile.PL39
1 files changed, 18 insertions, 21 deletions
diff --git a/ext/re/Makefile.PL b/ext/re/Makefile.PL
index bd0f1f741c..bc31b2c2cc 100644
--- a/ext/re/Makefile.PL
+++ b/ext/re/Makefile.PL
@@ -1,4 +1,6 @@
use ExtUtils::MakeMaker;
+use File::Spec;
+
WriteMakefile(
NAME => 're',
VERSION_FROM => 're.pm',
@@ -9,33 +11,28 @@ WriteMakefile(
clean => { FILES => '*$(OBJ_EXT) *.c ../../lib/re.pm' },
);
-sub MY::postamble {
- if ($^O eq 'VMS') {
- return <<'VMS_EOF';
-re_comp.c : [--]regcomp.c
- - $(RM_F) $(MMS$TARGET_NAME)
- $(CP) [--]regcomp.c $(MMS$TARGET_NAME)
+package MY;
-re_comp$(OBJ_EXT) : re_comp.c
+sub upupfile {
+ File::Spec->catfile(File::Spec->updir, File::Spec->updir, $_[0]);
+}
-re_exec.c : [--]regexec.c
- - $(RM_F) $(MMS$TARGET_NAME)
- $(CP) [--]regexec.c $(MMS$TARGET_NAME)
+sub postamble {
+ my $regcomp_c = upupfile('regcomp.c');
+ my $regexec_c = upupfile('regexec.c');
-re_exec$(OBJ_EXT) : re_exec.c
+ <<EOF;
+re_comp.c : $regcomp_c
+ - \$(RM_F) re_comp.c
+ \$(CP) $regcomp_c re_comp.c
+re_comp\$(OBJ_EXT) : re_comp.c
-VMS_EOF
- } else {
- return <<'EOF';
-re_comp.c: ../../regcomp.c
- -$(RM_F) $@
- $(CP) ../../regcomp.c $@
+re_exec.c : $regexec_c
+ - \$(RM_F) re_exec.c
+ \$(CP) $regexec_c re_exec.c
-re_exec.c: ../../regexec.c
- -$(RM_F) $@
- $(CP) ../../regexec.c $@
+re_exec\$(OBJ_EXT) : re_exec.c
EOF
- }
}