summaryrefslogtreecommitdiff
path: root/ext/threads/Makefile.PL
diff options
context:
space:
mode:
authorJarkko Hietaniemi <jhi@iki.fi>2002-04-17 14:31:42 +0000
committerJarkko Hietaniemi <jhi@iki.fi>2002-04-17 14:31:42 +0000
commit73e09c8fa5daeb8994c6d0aff5cfb8c4e65a7150 (patch)
tree4f804a7f284f3e67921e913c58544f310ecb8e96 /ext/threads/Makefile.PL
parent35a51b2056f806b70a212f2c12a7cf3433732011 (diff)
downloadperl-73e09c8fa5daeb8994c6d0aff5cfb8c4e65a7150.tar.gz
As suggested by Arthur: the threads and threads::shared
modules are always present. This tries to preempt two kinds of bug reports: (1) "the Perl 5.8.0 was supposed to have this new fancy threads implementation but my Perl doesn't seem to have it" (2) someone attempting to install threads using CPAN.pm and CPAN.pm helpfully starting to install perl 5.8.0 (which they might already have installed). p4raw-id: //depot/perl@15972
Diffstat (limited to 'ext/threads/Makefile.PL')
-rwxr-xr-xext/threads/Makefile.PL8
1 files changed, 0 insertions, 8 deletions
diff --git a/ext/threads/Makefile.PL b/ext/threads/Makefile.PL
index e2bf177fcf..fce2119978 100755
--- a/ext/threads/Makefile.PL
+++ b/ext/threads/Makefile.PL
@@ -2,14 +2,6 @@ use ExtUtils::MakeMaker;
# See lib/ExtUtils/MakeMaker.pm for details of how to influence
# the contents of the Makefile that is written.
-use Config;
-
-
-unless($Config{'useithreads'} eq 'define') {
- die "We need a perl that is built with USEITHREADS!\n";
-}
-
-
WriteMakefile(
'NAME' => 'threads',
'VERSION_FROM' => 'threads.pm', # finds $VERSION