summaryrefslogtreecommitdiff
path: root/ext/threads/Makefile.PL
diff options
context:
space:
mode:
authorJerry D. Hedden <jdhedden@cpan.org>2008-02-22 11:26:21 -0500
committerRafael Garcia-Suarez <rgarciasuarez@gmail.com>2008-02-25 06:45:05 +0000
commit7ef93cb2ba7dd1718be26a5d315eca2414c7da42 (patch)
treed49b0932769ba36e66bcd97e302498979efc1937 /ext/threads/Makefile.PL
parent54c0bb34295e9746f3d9fd2a6490265df2b6734c (diff)
downloadperl-7ef93cb2ba7dd1718be26a5d315eca2414c7da42.tar.gz
threads 1.69
From: "Jerry D. Hedden" <jdhedden@cpan.org> Message-ID: <1ff86f510802221326ib73c7e5kf26ad87086ee113d@mail.gmail.com> p4raw-id: //depot/perl@33359
Diffstat (limited to 'ext/threads/Makefile.PL')
-rwxr-xr-xext/threads/Makefile.PL19
1 files changed, 19 insertions, 0 deletions
diff --git a/ext/threads/Makefile.PL b/ext/threads/Makefile.PL
index 34fdb9f957..0321738450 100755
--- a/ext/threads/Makefile.PL
+++ b/ext/threads/Makefile.PL
@@ -67,6 +67,7 @@ if (grep { $_ eq 'PERL_CORE=1' } @ARGV) {
'Carp' => 0,
'XSLoader' => 0,
+ 'Test::More' => 0,
'ExtUtils::testlib' => 0,
'Hash::Util' => 0,
'IO::File' => 0,
@@ -93,4 +94,22 @@ WriteMakefile(
@conditional_params
);
+# Additional 'make' targets
+sub MY::postamble
+{
+ return <<'_EXTRAS_';
+fixfiles:
+ @dos2unix `cat MANIFEST`
+ @$(CHMOD) 644 `cat MANIFEST`
+ @$(CHMOD) 755 examples/*.pl
+
+ppport:
+ @( cd /tmp; perl -e 'use Devel::PPPort; Devel::PPPort::WriteFile("ppport.h");' )
+ @if ! cmp -s ppport.h /tmp/ppport.h; then \
+ ( tkdiff ppport.h /tmp/ppport.h & ); \
+ perl /tmp/ppport.h; \
+ fi
+_EXTRAS_
+}
+
# EOF