summaryrefslogtreecommitdiff
path: root/jpl/PerlInterpreter/Makefile.PL
diff options
context:
space:
mode:
authorGurusamy Sarathy <gsar@cpan.org>1999-09-15 02:57:08 +0000
committerGurusamy Sarathy <gsar@cpan.org>1999-09-15 02:57:08 +0000
commitb83c0eaa789c1e1527712ef4c3c985dde6539c3a (patch)
tree1d9da4e0d93624e886b42e699519739dcf6c0d7f /jpl/PerlInterpreter/Makefile.PL
parent30944b6df13d14ca352a3fdf86275e7fe6eb44b5 (diff)
downloadperl-b83c0eaa789c1e1527712ef4c3c985dde6539c3a.tar.gz
update to JPL snapshot v09141999, with minor tweaks (from Brian
Jepson <bjepson@home.com>) p4raw-id: //depot/perl@4159
Diffstat (limited to 'jpl/PerlInterpreter/Makefile.PL')
-rw-r--r--jpl/PerlInterpreter/Makefile.PL8
1 files changed, 6 insertions, 2 deletions
diff --git a/jpl/PerlInterpreter/Makefile.PL b/jpl/PerlInterpreter/Makefile.PL
index 76852c6cc8..b8b20f1e69 100644
--- a/jpl/PerlInterpreter/Makefile.PL
+++ b/jpl/PerlInterpreter/Makefile.PL
@@ -9,12 +9,16 @@ eval `$JPL_SRC/setvars -perl`;
if ($^O eq 'linux') {
$flags = "-Dbool=char"; # avoid builtin bool altogether
$libs = "-lc -lm -ldl";
-}
-else {
+} else {
$flags = "";
$libs = "-lc -lm -ldl";
}
+# Needed for JNI.
+if ($^O eq 'solaris') {
+ $libs .= " -lthread";
+}
+
open(MAKEFILE, ">Makefile");
print MAKEFILE <<"SUBS";