summaryrefslogtreecommitdiff
path: root/cpan/Sys-Syslog/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'cpan/Sys-Syslog/Makefile.PL')
-rw-r--r--cpan/Sys-Syslog/Makefile.PL3
1 files changed, 2 insertions, 1 deletions
diff --git a/cpan/Sys-Syslog/Makefile.PL b/cpan/Sys-Syslog/Makefile.PL
index 347197ab44..d09ba69fc9 100644
--- a/cpan/Sys-Syslog/Makefile.PL
+++ b/cpan/Sys-Syslog/Makefile.PL
@@ -3,6 +3,7 @@ use strict;
use ExtUtils::MakeMaker;
use File::Copy;
use File::Spec;
+use Config;
# create a typemap for Perl 5.6
@@ -33,7 +34,7 @@ if ($^O =~ /Win32/) {
$virtual_path{'win32/Win32.pm' } = '$(INST_LIBDIR)/Syslog/Win32.pm';
$virtual_path{'win32/PerlLog.dll'} = '$(INST_ARCHAUTODIR)/PerlLog.dll';
- push @extra_params, CCFLAGS => "-Ifallback";
+ push @extra_params, CCFLAGS => "$Config{ccflags} -Ifallback";
# recreate the DLL from its uuencoded form if it's not here
if (! -f File::Spec->catfile("win32", "$name.dll")) {