summaryrefslogtreecommitdiff
path: root/cpan/Win32/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'cpan/Win32/Makefile.PL')
-rw-r--r--cpan/Win32/Makefile.PL18
1 files changed, 18 insertions, 0 deletions
diff --git a/cpan/Win32/Makefile.PL b/cpan/Win32/Makefile.PL
new file mode 100644
index 0000000000..6f9b008823
--- /dev/null
+++ b/cpan/Win32/Makefile.PL
@@ -0,0 +1,18 @@
+use 5.006;
+use strict;
+use warnings;
+use ExtUtils::MakeMaker;
+
+unless ($^O eq "MSWin32" || $^O eq "cygwin") {
+ die "OS unsupported\n";
+}
+
+my %param = (
+ NAME => 'Win32',
+ VERSION_FROM => 'Win32.pm',
+ INSTALLDIRS => ($] >= 5.008004 ? 'perl' : 'site'),
+);
+$param{NO_META} = 1 if eval "$ExtUtils::MakeMaker::VERSION" >= 6.10_03;
+$param{LIBS} = ['-L/lib/w32api -lole32 -lversion'] if $^O eq "cygwin";
+
+WriteMakefile(%param);