summaryrefslogtreecommitdiff
path: root/dist/Safe/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'dist/Safe/Makefile.PL')
-rw-r--r--dist/Safe/Makefile.PL10
1 files changed, 10 insertions, 0 deletions
diff --git a/dist/Safe/Makefile.PL b/dist/Safe/Makefile.PL
new file mode 100644
index 0000000000..0463e9c7db
--- /dev/null
+++ b/dist/Safe/Makefile.PL
@@ -0,0 +1,10 @@
+use ExtUtils::MakeMaker;
+
+my $core = grep { $_ eq 'PERL_CORE=1' } @ARGV;
+
+WriteMakefile(
+ NAME => 'Safe',
+ VERSION_FROM => 'Safe.pm',
+ INSTALLDIRS => 'perl',
+ ($core || $] >= 5.011) ? () : (INST_LIB => '$(INST_ARCHLIB)'),
+);