summaryrefslogtreecommitdiff
path: root/ext/B/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'ext/B/Makefile.PL')
-rw-r--r--ext/B/Makefile.PL8
1 files changed, 4 insertions, 4 deletions
diff --git a/ext/B/Makefile.PL b/ext/B/Makefile.PL
index d39d3b5f9c..f38adb0ef8 100644
--- a/ext/B/Makefile.PL
+++ b/ext/B/Makefile.PL
@@ -28,7 +28,7 @@ package MY;
sub post_constants {
"\nLIBS = $Config::Config{libs}\n"
-}
+}
sub upupfile {
File::Spec->catfile(File::Spec->updir,
@@ -40,9 +40,9 @@ sub MY::postamble {
my $cop_h = upupfile('cop.h');
my $noecho = shift->{NOECHO};
"
-B\$(OBJ_EXT) : defsubs.h
+B\$(OBJ_EXT) : defsubs.h
-defsubs.h :: $op_h $cop_h
+defsubs.h :: $op_h $cop_h defsubs_h.PL
$noecho \$(NOOP)
-"
+"
}