summaryrefslogtreecommitdiff
path: root/ext/ByteLoader/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'ext/ByteLoader/Makefile.PL')
-rw-r--r--ext/ByteLoader/Makefile.PL12
1 files changed, 5 insertions, 7 deletions
diff --git a/ext/ByteLoader/Makefile.PL b/ext/ByteLoader/Makefile.PL
index 4aabe79683..1facb5a068 100644
--- a/ext/ByteLoader/Makefile.PL
+++ b/ext/ByteLoader/Makefile.PL
@@ -1,10 +1,8 @@
use ExtUtils::MakeMaker;
-# See lib/ExtUtils/MakeMaker.pm for details of how to influence
-# the contents of the Makefile that is written.
+
WriteMakefile(
- 'NAME' => 'ByteLoader',
- 'VERSION_FROM' => 'ByteLoader.pm', # finds $VERSION
- 'LIBS' => [''], # e.g., '-lm'
- 'DEFINE' => '', # e.g., '-DHAVE_SOMETHING'
- 'INC' => '-I$(PERL_SRC)', # e.g., '-I/usr/include/other'
+ NAME => 'ByteLoader',
+ VERSION_FROM => 'ByteLoader.pm',
+ XSPROTOARG => '-noprototypes',
+ OBJECT => 'byterun$(OBJ_EXT) ByteLoader$(OBJ_EXT)',
);