summaryrefslogtreecommitdiff
path: root/ext/Compress/IO/Base/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'ext/Compress/IO/Base/Makefile.PL')
-rw-r--r--ext/Compress/IO/Base/Makefile.PL41
1 files changed, 41 insertions, 0 deletions
diff --git a/ext/Compress/IO/Base/Makefile.PL b/ext/Compress/IO/Base/Makefile.PL
new file mode 100644
index 0000000000..2aaecb57e6
--- /dev/null
+++ b/ext/Compress/IO/Base/Makefile.PL
@@ -0,0 +1,41 @@
+#! perl -w
+
+use strict ;
+require 5.004 ;
+
+use private::MakeUtil;
+use ExtUtils::MakeMaker 5.16 ;
+
+UpDowngrade(getPerlFiles('MANIFEST'))
+ unless $ENV{PERL_CORE};
+
+WriteMakefile(
+ NAME => 'IO::Compress::Base',
+ VERSION_FROM => 'lib/IO/Compress/Base.pm',
+ 'dist' => { COMPRESS => 'gzip',
+ TARFLAGS => '-chvf',
+ SUFFIX => 'gz',
+ DIST_DEFAULT => 'MyTrebleCheck tardist',
+ },
+
+ (
+ $ENV{SKIP_FOR_CORE}
+ ? (MAN3PODS => {})
+ : (PREREQ_PM => { 'Scalar::Util' => 0,
+ $] >= 5.005 && $] < 5.006
+ ? ('File::BSDGlob' => 0)
+ : () }
+ )
+ ),
+
+ (
+ $] >= 5.005
+ ? (ABSTRACT_FROM => 'lib/IO/Compress/Base.pm',
+ AUTHOR => 'Paul Marquess <pmqs@cpan.org>')
+ : ()
+ ),
+
+) ;
+
+# end of file Makefile.PL
+