summaryrefslogtreecommitdiff
path: root/ext/Compress/Zlib/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'ext/Compress/Zlib/Makefile.PL')
-rwxr-xr-xext/Compress/Zlib/Makefile.PL13
1 files changed, 13 insertions, 0 deletions
diff --git a/ext/Compress/Zlib/Makefile.PL b/ext/Compress/Zlib/Makefile.PL
index b0fc295bfc..eea4402e7c 100755
--- a/ext/Compress/Zlib/Makefile.PL
+++ b/ext/Compress/Zlib/Makefile.PL
@@ -168,6 +168,19 @@ else {
or die "Can't copy fallback.xs to constants.xs: $!";
}
+sub MY::libscan
+{
+ my $self = shift ;
+ my $path = shift ;
+
+ return undef
+ if $path =~ /(~|\.bak|_bak)$/ ||
+ $path =~ /^\..*\.swp$/ ;
+
+ return $path;
+}
+
+
sub MY::postamble
{
my $postamble = <<'EOM';