summaryrefslogtreecommitdiff
path: root/ext/DB_File/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'ext/DB_File/Makefile.PL')
-rw-r--r--ext/DB_File/Makefile.PL6
1 files changed, 5 insertions, 1 deletions
diff --git a/ext/DB_File/Makefile.PL b/ext/DB_File/Makefile.PL
index 39b8bc7030..dbe19f1774 100644
--- a/ext/DB_File/Makefile.PL
+++ b/ext/DB_File/Makefile.PL
@@ -4,9 +4,13 @@ use Config ;
# OS2 is a special case, so check for it now.
my $OS2 = "-DOS2" if $Config{'osname'} eq 'os2' ;
+my $LIB = "-ldb" ;
+# so is win32
+$LIB = "-llibdb" if $^O eq 'MSWin32' ;
+
WriteMakefile(
NAME => 'DB_File',
- LIBS => ["-L/usr/local/lib -ldb"],
+ LIBS => ["-L/usr/local/lib $LIB"],
MAN3PODS => ' ', # Pods will be built by installman.
#INC => '-I/usr/local/include',
VERSION_FROM => 'DB_File.pm',