summaryrefslogtreecommitdiff
path: root/ext/Devel/PPPort/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'ext/Devel/PPPort/Makefile.PL')
-rw-r--r--ext/Devel/PPPort/Makefile.PL14
1 files changed, 2 insertions, 12 deletions
diff --git a/ext/Devel/PPPort/Makefile.PL b/ext/Devel/PPPort/Makefile.PL
index 0259a05e5a..f4cf6f5996 100644
--- a/ext/Devel/PPPort/Makefile.PL
+++ b/ext/Devel/PPPort/Makefile.PL
@@ -5,7 +5,8 @@ WriteMakefile(
DISTNAME => "Devel-PPPort",
VERSION_FROM=> 'PPPort.pm',
- #PM => {'PPPort.pm' => '$(INST_LIBDIR)/PPPort.pm'},
+ PL_FILES => { 'ppport_h.PL' => 'ppport.h' },
+ 'depend' => { '$(OBJECT)' => '$(H_FILES)' },
C => [qw(module2.c module3.c)],
H => [qw(ppport.h)],
OBJECT => '$(BASEEXT)$(OBJ_EXT) $(O_FILES)',
@@ -13,14 +14,3 @@ WriteMakefile(
'dist' => { COMPRESS=>"gzip", SUFFIX=>"gz" },
'clean' => { FILES => qw($(H_FILES))}
);
-
-sub MY::postamble {
- return <<"EOM";
-
-\$(H_FILES) : ppport_h.PL
- \$(PERLRUNINST) ppport_h.PL
-
-\$(OBJECT) : \$(H_FILES)
-
-EOM
-}