summaryrefslogtreecommitdiff
path: root/ext/Encode/KR/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'ext/Encode/KR/Makefile.PL')
-rw-r--r--ext/Encode/KR/Makefile.PL15
1 files changed, 15 insertions, 0 deletions
diff --git a/ext/Encode/KR/Makefile.PL b/ext/Encode/KR/Makefile.PL
index df0eeb68b2..4ba99ab82d 100644
--- a/ext/Encode/KR/Makefile.PL
+++ b/ext/Encode/KR/Makefile.PL
@@ -1,6 +1,7 @@
use 5.7.2;
use strict;
use ExtUtils::MakeMaker;
+use strict;
my %tables = (euc_kr_t => ['euc-kr.ucm',
'macKorean.ucm',
@@ -10,6 +11,20 @@ my %tables = (euc_kr_t => ['euc-kr.ucm',
johab_t => ['johab.ucm'],
);
+unless ($ENV{AGGREGATE_TABLES}){
+ my @ucm;
+ for my $k (keys %tables){
+ push @ucm, @{$tables{$k}};
+ }
+ %tables = ();
+ my $seq = 0;
+ for my $ucm (sort @ucm){
+ # 8.3 compliance !
+ my $t = sprintf ("%s_%02d_t", substr($ucm, 0, 2), $seq++);
+ $tables{$t} = [ $ucm ];
+ }
+}
+
my $name = 'KR';
WriteMakefile(