summaryrefslogtreecommitdiff
path: root/ext/File/Glob/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'ext/File/Glob/Makefile.PL')
-rw-r--r--ext/File/Glob/Makefile.PL10
1 files changed, 10 insertions, 0 deletions
diff --git a/ext/File/Glob/Makefile.PL b/ext/File/Glob/Makefile.PL
index c82988fdb1..98781c98e7 100644
--- a/ext/File/Glob/Makefile.PL
+++ b/ext/File/Glob/Makefile.PL
@@ -9,3 +9,13 @@ WriteMakefile(
# DEFINE => '-DGLOB_DEBUG',
# OPTIMIZE => '-g',
);
+use Config;
+sub MY::cflags {
+ package MY;
+ my $inherited = shift->SUPER::cflags(@_);
+ if ($Config::Config{archname} =~ /^aix/ and
+ $Config::Config{use64bitall} eq 'define') {
+ $inherited =~ s/\s-O\d?//m;
+ }
+ $inherited;
+}