summaryrefslogtreecommitdiff
path: root/ext/GDBM_File/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'ext/GDBM_File/Makefile.PL')
-rw-r--r--ext/GDBM_File/Makefile.PL7
1 files changed, 6 insertions, 1 deletions
diff --git a/ext/GDBM_File/Makefile.PL b/ext/GDBM_File/Makefile.PL
index 754416047d..c635941cac 100644
--- a/ext/GDBM_File/Makefile.PL
+++ b/ext/GDBM_File/Makefile.PL
@@ -25,7 +25,12 @@ push @names, {
GDBM_SNAPSHOT_SAME GDBM_SNAPSHOT_SUSPICIOUS);
# Basic error codes - these are supported by all versions of gdbm
-push @names, qw(
+push @names, {
+ name => $_,
+ value => "$_",
+ type => "IV",
+ macro => 1
+} foreach qw(
GDBM_NO_ERROR
GDBM_MALLOC_ERROR
GDBM_BLOCK_SIZE_ERROR