summaryrefslogtreecommitdiff
path: root/ext/SDBM_File/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'ext/SDBM_File/Makefile.PL')
-rw-r--r--ext/SDBM_File/Makefile.PL19
1 files changed, 19 insertions, 0 deletions
diff --git a/ext/SDBM_File/Makefile.PL b/ext/SDBM_File/Makefile.PL
new file mode 100644
index 0000000000..17c16b104b
--- /dev/null
+++ b/ext/SDBM_File/Makefile.PL
@@ -0,0 +1,19 @@
+use ExtUtils::MakeMaker;
+
+# The existence of the ./sdbm/Makefile.PL file causes MakeMaker
+# to automatically include Makefile code for the targets
+# config, all, clean, realclean and sdbm/Makefile
+# which perform the corresponding actions in the subdirectory.
+
+WriteMakefile(
+ 'MYEXTLIB' => 'sdbm/libsdbm.a',
+);
+
+
+sub MY::postamble {
+ '
+$(MYEXTLIB): sdbm/Makefile
+ cd sdbm; $(MAKE) all
+';
+}
+