summaryrefslogtreecommitdiff
path: root/ext/SDBM_File/sdbm/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'ext/SDBM_File/sdbm/Makefile.PL')
-rw-r--r--ext/SDBM_File/sdbm/Makefile.PL35
1 files changed, 7 insertions, 28 deletions
diff --git a/ext/SDBM_File/sdbm/Makefile.PL b/ext/SDBM_File/sdbm/Makefile.PL
index 1994f052b4..f42a1651aa 100644
--- a/ext/SDBM_File/sdbm/Makefile.PL
+++ b/ext/SDBM_File/sdbm/Makefile.PL
@@ -4,46 +4,25 @@ WriteMakefile(
'DEFINE' => '-DSDBM -DDUFF',
'SKIP' => [qw(static static_lib dynamic dynamic_lib)],
'clean'
- => {'FILES' => 'dbu libsdbm.a dbd dba dbe x-dbu *.dir *.pag'}
+ => {'FILES' => 'dbu libsdbm.a dbd dba dbe x-dbu *.dir *.pag'},
+ 'H' => [qw(tune.h sdbm.h pair.h $(PERL_INC)/config.h)],
+ 'C' => [qw(sdbm.c pair.c hash.c)]
);
sub MY::top_targets {
'
-LIBOBJS = sdbm.o pair.o hash.o
-LIBSRCS = sdbm.c pair.c hash.c
-HDRS = tune.h sdbm.h pair.h
-
all :: static
static :: libsdbm.a
-libsdbm.a: $(LIBOBJS)
- ar cr libsdbm.a $(LIBOBJS)
- $(RANLIB) libsdbm.a
-
-$(LIBOBJS): $(HDRS) $(PERL_INC)/config.h
-
config ::
+libsdbm.a: $(O_FILES)
+ ar cr libsdbm.a $(O_FILES)
+ $(RANLIB) libsdbm.a
+
lint:
lint -abchx $(LIBSRCS)
';
}
-
-
-sub MY::realclean {
- '
-realclean :: clean
- rm -f Makefile
-';
-}
-
-
-sub MY::postamble {
- '
-sdbm.o : sdbm.c $(PERL_INC)/config.h sdbm.h tune.h pair.h
-hash.o : hash.c $(PERL_INC)/config.h sdbm.h
-pair.o : pair.c $(PERL_INC)/config.h sdbm.h tune.h pair.h
-';
-}