summaryrefslogtreecommitdiff
path: root/ext/re/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'ext/re/Makefile.PL')
-rw-r--r--ext/re/Makefile.PL22
1 files changed, 22 insertions, 0 deletions
diff --git a/ext/re/Makefile.PL b/ext/re/Makefile.PL
new file mode 100644
index 0000000000..c6a55a6f44
--- /dev/null
+++ b/ext/re/Makefile.PL
@@ -0,0 +1,22 @@
+use ExtUtils::MakeMaker;
+WriteMakefile(
+ NAME => 're',
+ VERSION_FROM => 're.pm',
+ MAN3PODS => ' ', # Pods will be built by installman.
+ XSPROTOARG => '-noprototypes',
+ OBJECT => 're_exec$(OBJ_EXT) re_comp$(OBJ_EXT) re$(OBJ_EXT)',
+ DEFINE => '-DDEBUGGING -DIN_XSUB_RE',
+);
+
+sub MY::postamble {
+ return <<'EOF';
+re_comp.c: ../../regcomp.c
+ -$(RM) $@
+ $(CP) ../../regcomp.c $@
+
+re_exec.c: ../../regexec.c
+ -$(RM) $@
+ $(CP) ../../regexec.c $@
+
+EOF
+}