summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSascha Schumann <sas@php.net>1999-10-05 13:27:37 +0000
committerSascha Schumann <sas@php.net>1999-10-05 13:27:37 +0000
commit84df96ef37607f1e669353b9f0be1fa86dc6e77f (patch)
tree0bb82f02e9c2fc5aed508d14dc305d1bd439baf1 /Makefile.am
parente0fe7b9c034bc2ba037463460aa860268574a6f6 (diff)
downloadphp-git-84df96ef37607f1e669353b9f0be1fa86dc6e77f.tar.gz
Fix automake dependencies
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 29b0b34936..91d0f26697 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,11 +15,22 @@ libphp4_la_SOURCES = \
php_ini.c SAPI.c rfc1867.c dlist.c php_content_types.c strlcpy.c \
strlcat.c
-libphp4_la_LIBADD = libzend/libzend.la \
+libphp4_la_LIBADD = \
+ libzend/libzend.la \
sapi/$(PHP_SAPI)/libphpsapi_$(PHP_SAPI).la \
- regex/libregex.la $(EXT_LTLIBS) $(TSRM_LIB) $(EXTRA_LIBS)
+ regex/libregex.la \
+ $(EXT_LTLIBS) \
+ $(TSRM_LIB) \
+ $(EXTRA_LIBS)
libphp4_la_LDFLAGS = -avoid-version $(BUILDLDFLAGS) $(PHP_RPATHS)
+libphp4_la_DEPENDENCIES = \
+ libzend/libzend.la \
+ sapi/$(PHP_SAPI)/libphpsapi_$(PHP_SAPI).la \
+ regex/libregex.la \
+ $(EXT_LTLIBS) \
+ $(TSRM_LIB)
+
configuration-parser.h configuration-parser.c: configuration-parser.y
$(YACC) -p cfg -v -d $< -o configuration-parser.c