summaryrefslogtreecommitdiff
path: root/Zend/Makefile.am
diff options
context:
space:
mode:
authorSascha Schumann <sas@php.net>1999-12-23 13:29:26 +0000
committerSascha Schumann <sas@php.net>1999-12-23 13:29:26 +0000
commit9156d86009d8343b2e39d8f33b1718f4a7f8ac52 (patch)
treefbc9d9b6d847af81634fa8337f6513b256342886 /Zend/Makefile.am
parenta04805ce889fd24120da713a65d982183626ef67 (diff)
downloadphp-git-9156d86009d8343b2e39d8f33b1718f4a7f8ac52.tar.gz
Compile zend_execute.c with special CFLAGS. For GCC, INLINE_CFLAGS
contains -O0 to disable optimizations. This can be disabled by using the appropiate parameter.
Diffstat (limited to 'Zend/Makefile.am')
-rw-r--r--Zend/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Zend/Makefile.am b/Zend/Makefile.am
index 9a78e162d3..190170c728 100644
--- a/Zend/Makefile.am
+++ b/Zend/Makefile.am
@@ -20,7 +20,7 @@ libZend_la_SOURCES=\
libZend_la_LIBADD = $(ZEND_SCANNER)
libZend_la_LDFLAGS = @EXTRA_LIBS@
libZend_la_DEPENDENCIES = $(ZEND_SCANNER)
-
+
# automake isn't too clever about "non-standard" use of lex and yacc
zend-scanner.l: zend-parser.h
@@ -35,3 +35,5 @@ zend-parser.h: zend-parser.c
zend-parser.c: zend-parser.y
$(YACC) -p zend -v -d $(srcdir)/zend-parser.y -o zend-parser.c
+zend_execute.lo: $(srcdir)/zend_execute.c
+ $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) $(CPPFLAGS) $(INLINE_CFLAGS) -c $(srcdir)/zend_execute.c