summaryrefslogtreecommitdiff
path: root/Zend/configure.in
diff options
context:
space:
mode:
authorStig S. Bakken <stig@php.net>1999-09-13 11:29:44 +0000
committerStig S. Bakken <stig@php.net>1999-09-13 11:29:44 +0000
commitaf1e5ad88148fc7aa23879ce2ef69d422a3a8f39 (patch)
tree27bda607863be795125c1f8d39fe157a1ba07e69 /Zend/configure.in
parentf858b6891ce118db804627f5f751c327beb1b85f (diff)
downloadphp-git-af1e5ad88148fc7aa23879ce2ef69d422a3a8f39.tar.gz
Make sure HAVE_LIBDL gets defined.
Disable more C++ tests when not configured for thread safety.
Diffstat (limited to 'Zend/configure.in')
-rw-r--r--Zend/configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/Zend/configure.in b/Zend/configure.in
index 1aa6b7b27a..c501c52e28 100644
--- a/Zend/configure.in
+++ b/Zend/configure.in
@@ -65,10 +65,12 @@ AC_HEADER_STDC
dnl QNX requires unix.h to allow functions in libunix to work properly
AC_CHECK_HEADERS(limits.h malloc.h string.h unistd.h stdarg.h sys/types.h signal.h unix.h dlfcn.h)
+if test "$enable_thread_safety" = "yes" ; then
dnl C++ specific header files
AC_LANG_CPLUSPLUS
AC_CHECK_HEADER(stdiostream.h, [ AC_DEFINE(HAVE_STDIOSTREAM_H) ])
AC_LANG_C
+fi
dnl Checks for types
AC_TYPE_SIZE_T