summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikita Popov <nikita.ppv@gmail.com>2017-02-06 01:47:09 +0100
committerNikita Popov <nikita.ppv@gmail.com>2017-02-06 01:47:09 +0100
commit31332d094127b6332018cd146b9becbd7566e60c (patch)
treea897cfa6078fe29e6cae07a423eaf807cd2c423b /configure.ac
parentb73190d91903f2fa8487746403efbb006d84321e (diff)
parent546af1966e56a90ba7ce5ccd434c63b60f14881e (diff)
downloadphp-git-31332d094127b6332018cd146b9becbd7566e60c.tar.gz
Merge branch 'PHP-7.1'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 8326895a3d..5584a4f43a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -68,7 +68,7 @@ int zend_sprintf(char *buffer, const char *format, ...);
#include <math.h>
#ifndef zend_isnan
-#ifdef HAVE_DECL_ISNAN
+#ifdef HAVE_ISNAN
#define zend_isnan(a) isnan(a)
#elif defined(HAVE_FPCLASS)
#define zend_isnan(a) ((fpclass(a) == FP_SNAN) || (fpclass(a) == FP_QNAN))
@@ -77,18 +77,18 @@ int zend_sprintf(char *buffer, const char *format, ...);
#endif
#endif
-#ifdef HAVE_DECL_ISINF
+#ifdef HAVE_ISINF
#define zend_isinf(a) isinf(a)
#elif defined(INFINITY)
/* Might not work, but is required by ISO C99 */
-#define zend_isinf(a) (((a)==INFINITY || (a)==-INFINITY)?1:0)
+#define zend_isinf(a) (((a)==INFINITY)?1:0)
#elif defined(HAVE_FPCLASS)
#define zend_isinf(a) ((fpclass(a) == FP_PINF) || (fpclass(a) == FP_NINF))
#else
#define zend_isinf(a) 0
#endif
-#if defined(HAVE_DECL_ISINFINITE) || defined(isfinite)
+#if defined(HAVE_ISFINITE) || defined(isfinite)
#define zend_finite(a) isfinite(a)
#elif defined(HAVE_FINITE)
#define zend_finite(a) finite(a)