summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAnatol Belski <ab@php.net>2018-07-08 20:34:58 +0200
committerAnatol Belski <ab@php.net>2018-07-08 20:34:58 +0200
commitd664d1e9592ad923ce8656201cb6f85f87ed394c (patch)
tree2f1b78c76b5f415cc451ad5d3d4062e490e136ac /configure.ac
parente4a2cdb564ade42d994c37c99cb95954047b5cb7 (diff)
parent545a29d0cb8e57cc6739649130a9ad6e08874c74 (diff)
downloadphp-git-d664d1e9592ad923ce8656201cb6f85f87ed394c.tar.gz
Merge branch 'PHP-7.2'
* PHP-7.2: Fix C++11 and up compatibility for zend_finite and more
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 8a664bc442..c37684cb3e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -68,7 +68,7 @@ int zend_sprintf(char *buffer, const char *format, ...);
#include <math.h>
#ifndef zend_isnan
-#if HAVE_DECL_ISNAN
+#if HAVE_DECL_ISNAN && (!defined(__cplusplus) || __cplusplus < 201103L)
#define zend_isnan(a) isnan(a)
#elif defined(HAVE_FPCLASS)
#define zend_isnan(a) ((fpclass(a) == FP_SNAN) || (fpclass(a) == FP_QNAN))
@@ -77,7 +77,7 @@ int zend_sprintf(char *buffer, const char *format, ...);
#endif
#endif
-#if HAVE_DECL_ISINF
+#if HAVE_DECL_ISINF && (!defined(__cplusplus) || __cplusplus < 201103L)
#define zend_isinf(a) isinf(a)
#elif defined(INFINITY)
/* Might not work, but is required by ISO C99 */
@@ -88,7 +88,7 @@ int zend_sprintf(char *buffer, const char *format, ...);
#define zend_isinf(a) 0
#endif
-#if HAVE_DECL_ISFINITE
+#if HAVE_DECL_ISFINITE && (!defined(__cplusplus) || __cplusplus < 201103L)
#define zend_finite(a) isfinite(a)
#elif defined(HAVE_FINITE)
#define zend_finite(a) finite(a)