summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Kokot <peterkokot@gmail.com>2018-08-25 20:52:28 +0200
committerPeter Kokot <peterkokot@gmail.com>2018-08-29 02:04:48 +0200
commit3748d8070ffd7750c73c327e212d6dc4fc76d427 (patch)
treec5c8287e14334de922bcb92445bd1287e191bf00 /configure.ac
parent03fc3d85d8a0624c7a1171576db9cf44575763b0 (diff)
downloadphp-git-3748d8070ffd7750c73c327e212d6dc4fc76d427.tar.gz
Implement #64517: Add AC_ARG_PROGRAM macro
The AC_ARG_PROGRAM Autoconf macro provides program name transformations when installing. This patch implements #64517 and prepares the implementation for the request #60518. In ./configure --help it additionally outputs --program-prefix=PREFIX, --program-suffix=SUFFIX and the upcoming --program-transform-name=PROGRAM option. Macro AC_ARG_PROGRAM is available since Autoconf 2.0 and needs to be called after the AC_CANONICAL_TARGET macro. Refs: - https://www.gnu.org/software/autoconf/manual/autoconf-2.69/html_node/Transforming-Names.html
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8ec2ee2369..7249f59f96 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1207,6 +1207,8 @@ EXTRA_LDFLAGS_PROGRAM="$EXTRA_LDFLAGS_PROGRAM $LDFLAGS"
EXTRA_LIBS="$EXTRA_LIBS $LIBS"
unset LIBS LDFLAGS
+AC_ARG_PROGRAM
+
test "$prefix" = "NONE" && prefix=/usr/local
test "$exec_prefix" = "NONE" && exec_prefix='${prefix}'
test "$program_prefix" = "NONE" && program_prefix=