summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristoph M. Becker <cmbecker69@gmx.de>2018-09-11 12:23:20 +0200
committerChristoph M. Becker <cmbecker69@gmx.de>2018-09-11 12:23:20 +0200
commitb117feeb2b545b34296f2fc492166d790610fffe (patch)
tree6d1ba7307fad5eaea0f2f13829feb9b0b7b2fe71 /configure.ac
parent1bb29a4af22bb11c4257e475c691c3a75b5859a3 (diff)
downloadphp-git-b117feeb2b545b34296f2fc492166d790610fffe.tar.gz
Fix #76510: file_exists() stopped working for phar://
We work around a strlen() optimization bug in GCC 8[1] by checking whether the used GCC exhibits the broken behavior, and if so by disabling `optimize-strlen`. [1] <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=86914>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 78a1878c25..dafe25e529 100644
--- a/configure.ac
+++ b/configure.ac
@@ -503,6 +503,9 @@ immintrin.h
PHP_FOPENCOOKIE
PHP_BROKEN_GETCWD
PHP_BROKEN_GLIBC_FOPEN_APPEND
+if test "$GCC" = "yes"; then
+ PHP_BROKEN_GCC_STRLEN_OPT
+fi
dnl Checks for typedefs, structures, and compiler characteristics.
dnl -------------------------------------------------------------------------