summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Kokot <petk@php.net>2018-07-28 23:09:06 +0200
committerPeter Kokot <peterkokot@gmail.com>2018-07-29 16:04:39 +0200
commitdaaf706df07f045bfe85a3d48905857ca93dc27f (patch)
tree4eaa36a391944a77a5796e2ea26e4f82958dd343 /configure.ac
parent7394879adfeac2fa8e9e2fc3cc5a0e48857592ba (diff)
downloadphp-git-daaf706df07f045bfe85a3d48905857ca93dc27f.tar.gz
Upgrade deprecated AC_OUTPUT macro calls
Autoconf 2.50 made several changes to macro calls. These include also arguments passed to AC_OUTPUT macro. The upgrading chapter in Autoconf documentation include an example of using AC_OUTPUT with AC_CONFIG_FILES and AC_CONFIG_COMMANDS: - https://www.gnu.org/software/autoconf/manual/autoconf-2.69/html_node/Obsolete-Macros.html PHP 5.4 to 7.1 require Autoconf 2.59+, PHP 7.2+ require Autoconf 2.64+, and PHP 7.2 phpize script requires Autoconf 2.59+ which are all greater than above mentioned 2.50 version. Systems out there should well support this by now. This patch was created with the help of autoupdate script: autoupdate <file> More info on where exactly this got deprecated: - ftp://ftp.gnu.org/old-gnu/Manuals/autoconf-2.13/html_mono/autoconf.html - ftp://ftp.auckland.ac.nz/pub/gnu/Manuals/autoconf-2.52/html_chapter/autoconf_15.html - http://git.savannah.gnu.org/cgit/autoconf.git/tree/NEWS
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 98d567a587..e7530f70a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1567,7 +1567,8 @@ PHP_CHECK_CONFIGURE_OPTIONS
dnl
dnl Generate build files
dnl
-AC_OUTPUT($ALL_OUTPUT_FILES, [], [
+AC_CONFIG_FILES([$ALL_OUTPUT_FILES])
+AC_CONFIG_COMMANDS([default],[],[
if test "\$CONFIG_FILES" = "$ALL_OUTPUT_FILES" || test "\$CONFIG_FILES" = " $ALL_OUTPUT_FILES" || test -z "\$CONFIG_FILES"; then
REDO_ALL=yes
@@ -1698,6 +1699,7 @@ Check '[$]0 --help' for available options
fi
])
+AC_OUTPUT
dnl ## Local Variables:
dnl ## tab-width: 4