summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorXinchen Hui <laruence@gmail.com>2018-02-10 17:01:55 +0800
committerXinchen Hui <laruence@gmail.com>2018-02-10 17:01:55 +0800
commit7ce72f0cf5c0b5bc458bee90698e19fb417d8b96 (patch)
tree19b919990d77cb7913e616f2068eed108f7773e3 /configure.ac
parent87b71804804a0a76115267a34acd27b7d01d6e85 (diff)
parentd3cb224eb3074c6f467f135c6554b1a0b14e835e (diff)
downloadphp-git-7ce72f0cf5c0b5bc458bee90698e19fb417d8b96.tar.gz
Merge branch 'master' of git.php.net:/php-src
* 'master' of git.php.net:/php-src: (37 commits) Avoid conditions inside loop Improve loop vectorization Improve loop vectorization Remove unused function Fixed bug #75938 Remove unused files Fixed bug #75940 Unnecessary compile wrapper with PHP_THREAD_SAFETY=yes typo Update README.GIT-RULES Fix SKIPIF section Fixes bug #75871 Use pkg-config for libxml2 if available Fixed bug #49876 lib path on 64bit distros Refactor testing READMEs Fixed bug #65414 Fixed bug #65414 Fixed bug #74519 strange behavior of AppendIterator fix #74519 strange behavior of AppendIterator Use bool instead of boolean Remove space between function name and open parentheses Fix some misspellings ...
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 1 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index d9f1e3fe1b..4d754364db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1379,12 +1379,7 @@ old_CC=$CC
if test "$PHP_THREAD_SAFETY" = "yes" && test -n "$ac_cv_pthreads_cflags"; then
CXXFLAGS="$CXXFLAGS $ac_cv_pthreads_cflags"
INLINE_CFLAGS="$INLINE_CFLAGS $ac_cv_pthreads_cflags"
- cat >meta_ccld<<EOF
-#! /bin/sh
-exec $CC $ac_cv_pthreads_cflags \$@
-EOF
- CC="$abs_builddir/meta_ccld"
- chmod +x meta_ccld
+ CPPFLAGS="$CPPFLAGS $ac_cv_pthreads_cflags"
fi
dnl This will go away, if we have a facility to run per-extension code