summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Kokot <peterkokot@gmail.com>2019-06-28 23:10:37 +0200
committerPeter Kokot <peterkokot@gmail.com>2019-06-30 23:57:54 +0200
commit9a3c8e51e3ee33a4f9a414f79af09489273e0b92 (patch)
treea4d65558f469d7c459e46ab8febc5ae51cfc35c6 /configure.ac
parent8bc59a62c43bd38938a076e0c28edc42322dcea1 (diff)
downloadphp-git-9a3c8e51e3ee33a4f9a414f79af09489273e0b92.tar.gz
Sync functions checks
Removed unused checks: - mbsinit check removed, HAVE_MBSINIT removed (not used in php-src) - mempcpy check removed, HAVE_MEMPCPY removed (not used in php-src anymore since 560ed89bfbb56526251e9bd2fbcb27e5932641d8 which uses PHP's own implementation) - strpncpy check removed, added via a8c9e893b6911c785f698d724b2ff61e7aebb737 and not used. - setpgid check removed since HAVE_SETPGID is not used Moved to a central configure.ac: - fpclass - mbrlen moved to configure.ac (since the HAVE_MBRLEN is used accross the php-src) - sigprocmask - getcwd - getwd - glob - strfmon - nice Duplicated checks removed: - gethostname - getlogin - getpwuid_r - socketpair - mprotect check simplified
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index eeb806f639..5a230200ca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -592,23 +592,26 @@ cuserid \
crypt \
explicit_memset \
flock \
+fpclass \
ftok \
funopen \
gai_strerror \
gcvt \
+getcwd \
getloadavg \
getlogin \
getprotobyname \
getprotobynumber \
getservbyname \
getservbyport \
-gethostname \
getrusage \
gettimeofday \
gmtime_r \
getpwnam_r \
getgrnam_r \
getpwuid_r \
+getwd \
+glob \
grantpt \
inet_ntoa \
inet_ntop \
@@ -619,9 +622,11 @@ localtime_r \
lockf \
lchown \
lrand48 \
+mbrlen \
memmove \
mkstemp \
mmap \
+nice \
nl_langinfo \
poll \
ptsname \
@@ -632,10 +637,10 @@ rand_r \
scandir \
setitimer \
setenv \
-setpgid \
setsockopt \
setvbuf \
shutdown \
+sigprocmask \
sin \
srand48 \
srandom \
@@ -645,6 +650,7 @@ std_syslog \
strcasecmp \
strdup \
strerror \
+strfmon \
strnlen \
strptime \
strtok_r \