summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2018-05-14 17:25:37 -0400
committerNikita Popov <nikita.ppv@gmail.com>2018-11-07 13:05:47 +0100
commit2d03197749696ac3f8effba6b7977b0d8729fef3 (patch)
tree2c7327c6007ce3f175bb81e9ae489e6abc189132 /configure.ac
parentf20029807560677077f3f94764caada869329e26 (diff)
downloadphp-git-2d03197749696ac3f8effba6b7977b0d8729fef3.tar.gz
ext/gd: Use pkg-config to detect the availability of freetype2
The latest version of freetype2 does not install freetype-config by default, but pkg-config support has been there for approximately 15 years. In order to reliably detect freetype2, pkg-config *must* be used. See: https://savannah.nongnu.org/bugs/?53093 https://bugs.php.net/bug.php?id=76324
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 46a6975318..f6ccd62487 100644
--- a/configure.ac
+++ b/configure.ac
@@ -177,6 +177,7 @@ rm -f libs/*
dnl Checks for programs.
dnl -------------------------------------------------------------------------
+PKG_PROG_PKG_CONFIG
AC_PROG_CC([cc gcc])
PHP_DETECT_ICC
PHP_DETECT_SUNCC