summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Kokot <peterkokot@gmail.com>2019-07-18 12:11:19 +0200
committerPeter Kokot <peterkokot@gmail.com>2019-07-18 12:11:19 +0200
commitbbdbc2658cb60b42652a398571de6402b5007f54 (patch)
tree2917ba69233e8532f4127dc83f47fc1b1d441536 /configure.ac
parent562591f5eb3ff71711a06da21e552932bff82c08 (diff)
downloadphp-git-bbdbc2658cb60b42652a398571de6402b5007f54.tar.gz
Remove duplicate socklen_t check
- Use Autoconf's default AC_CHECK_TYPES Closes GH-4418
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 67082077c8..36c6e5e3e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -498,7 +498,15 @@ AC_STRUCT_TIMEZONE
PHP_MISSING_TIME_R_DECL
PHP_MISSING_FCLOSE_DECL
PHP_STRUCT_FLOCK
-PHP_SOCKLEN_T
+
+AC_CHECK_TYPES(socklen_t, [], [], [
+ #ifdef HAVE_SYS_TYPES_H
+ # include <sys/types.h>
+ #endif
+ #ifdef HAVE_SYS_SOCKET_H
+ # include <sys/socket.h>
+ #endif
+])
dnl These are defined elsewhere than stdio.h.
PHP_CHECK_SIZEOF(intmax_t, 0)